Carburetor Settings Question (Idle Screw)

P

pfrederi1

Well-Known Member
Messages
85
Likes
4
Hello Im new to this forum and this is my second post. I know theres info out there but i cant seem to find specific info on what Im asking. I have a Walbro 668 carb and having trouble getting it tuned to run right. I believe my settings are out of whack for the needles including the IDLE. My question is does anyone know what the idle screw setting is supposed to be set at for a baseline start? Im not sure and I keep fudging with it. The engine starts but if I didnt have it off the ground it would take off immediately because its revving so hi. i tried adjusting the idle but its giving weird feedback. If the revs do drop itll cutoff. I tried finding the sweetspot but it seems to only likes crazy hi revs or low then shut off. Its crazy.


If someone can re-educate me on what turns do what on these needles (H, L, Idle) id appreciate it. I forgot which direction turn increases revs and which direction increases air or gas. I had it memorized at one point but im all turned around now. Coupled with that the responses that i get when i try to adjust the needles are not jiving. The engine is revving like crazy and my eardrums are shot.


Idle:??? (Whats a good starting point for the IDLE?)
Hi: 1 5/8
Lo: 1 3/8

Can you give any help\suggestions on this? Any help is greatly appreciated. Hoping to get his thing idling\running right again.

Thx
 
G-Man

G-Man

Junior Member
Messages
800
Likes
124
Location
Pittsburgh,PA
Sounds like the low needle is adjusted incorrectly if the idle screw doesn't operate properly. I am trying to find the stock baseline settings for that carb. Gimme a minute
 
G-Man

G-Man

Junior Member
Messages
800
Likes
124
Location
Pittsburgh,PA
Hello Im new to this forum and this is my second post. I know theres info out there but i cant seem to find specific info on what Im asking. I have a Walbro 668 carb and having trouble getting it tuned to run right. I believe my settings are out of whack for the needles including the IDLE. My question is does anyone know what the idle screw setting is supposed to be set at for a baseline start? Im not sure and I keep fudging with it. The engine starts but if I didnt have it off the ground it would take off immediately because its revving so hi. i tried adjusting the idle but its giving weird feedback. If the revs do drop itll cutoff. I tried finding the sweetspot but it seems to only likes crazy hi revs or low then shut off. Its crazy.


If someone can re-educate me on what turns do what on these needles (H, L, Idle) id appreciate it. I forgot which direction turn increases revs and which direction increases air or gas. I had it memorized at one point but im all turned around now. Coupled with that the responses that i get when i try to adjust the needles are not jiving. The engine is revving like crazy and my eardrums are shot.


Idle:??? (Whats a good starting point for the IDLE?)
Hi: 1 5/8
Lo: 1 3/8

Can you give any help\suggestions on this? Any help is greatly appreciated. Hoping to get his thing idling\running right again.

Thx
https://www.redcatrampageforum.com/threads/needle-settings-668-carb-30cc-fuelie.6359/
 
P

pfrederi1

Well-Known Member
Messages
85
Likes
4
Thx G-Man. Tried those settings still same response. When it does start engine just takes off hi revs. I tried bot ways with HI 1 1/4 and LO 1 1/2 and then flipped them. When flipped doesn't start. Not sure whats causing the engine to rev out of control. no idea. If its an engine problem what could cause this?

Intake manifold? I found no leaks. everything is torqued down to the point of being a bit overtighten. What would cause an engine to over rev as soon as its cranked up? scary.

Ive tried two other carbs i have that are questionable but worked before. I know theyre good but my lack of knowledge in the tuning and settings may have thrown them off.

Again need help as to what fix may be.

Carb 668 and 997 same results
Thx
 
P

pfrederi1

Well-Known Member
Messages
85
Likes
4
Update. I ordered and installed brand new carb 668 from DDM. Same issue. Starts but with crazy HI revs i have to shut the engine off immediately for fear the engine might seize or blow up or something. Added to that to save my eardrums. I let run a lil couple times just to see if idle would settle down but nope just revs like a bat outta hell. The throttle is not engaged either, ive checked that.

Does anyone know what could be causing this issue???!!! I ruled out the carbs because ive tried several (new and used) and they all exhibit the same issue so I dnt think its the carb. What would make an engine do that?!!!!

So now ive got one truck that wont start and a car that starts but revs like a crazy bat. Funny thing is they were both running and with no indication (no accidents or anything just would not start and the other over revs like crazy. LOL!!!! Gotta love it This Thing is a pain the a$$. IM SERIOUSLY CONSIDERING GOING BACK TO ELECTRIC!!!!! TOO MUCH INCONSISTENCIES WITH THIS GAS MAN!!!!
 
Last edited:
sunoco

sunoco

Well-Known Member
Messages
165
Likes
29
if you are shure the intake manafold does not have a air leak, it has to be leaking elsewhere. either the gasket that seals the lower engine cases-- and or-- the crankshaft seals. thats all i can think of with out actually looking at it in person.

crank seals- about 8 dollars. crankcase gasket- about 3 dollars. yea i would be smoking too- thing is, ya gotta learn how to do the repairs yourself. same with anything really- half ass building contractors- goof ball automobile repair shops-- its endless. darned shame i live up in central washington- i would repair it for nothing- you buy parts- watch and learn. --- in my humble opinion- best bang for the money engine? cy-f270. complete engine at daves discount motors- 220 bucks- free shipping. -
 
P

pfrederi1

Well-Known Member
Messages
85
Likes
4
Latest update I managed to get the revs down and idling close to normal. That came from me basically getting lucky and messing with the needles on the NEWcarb (668) because it had no effect on the old carbs that i tried. So now it idles but sometimes erratic. When i took it out this weekend and try to run it idles ok but when i hit the throttle it bogs down heavily and sometimes cuts out before even getting revs to take off. I mean serious bogging down (2 sec) before the engine rev kicks in (and no its not the linkage or transmitter settings or gas feed bubbles). It drove but cuts out. For me to take off i have to hit the accelarator WOT quickly a few times before it cuts out for it to actually drive.

So i figured since its idling somewhat ok then maybe my problem is I need to richen the hi speed so that it can take off when i hit the throttle and not bog down and die out. No luck there. I also tried richen the LSN which in turn i had to turn out the idle to keep it from dying out. So what do i do?

Other question at what point does the hi sped needle settings kick in? and is this issue more with the lo speed or hi speed? or both?

Current setting Carb 668
(Further adjustments seem to have no effect on improving the bogging down; maybe im doing it wrong)
LSN:- 3/4
HSN:- 1

Appreciate some input as to what I need to do nxt.
Thx
 
P

pfrederi1

Well-Known Member
Messages
85
Likes
4
if you are shure the intake manafold does not have a air leak, it has to be leaking elsewhere. either the gasket that seals the lower engine cases-- and or-- the crankshaft seals. thats all i can think of with out actually looking at it in person.

crank seals- about 8 dollars. crankcase gasket- about 3 dollars. yea i would be smoking too- thing is, ya gotta learn how to do the repairs yourself. same with anything really- half ass building contractors- goof ball automobile repair shops-- its endless. darned shame i live up in central washington- i would repair it for nothing- you buy parts- watch and learn. --- in my humble opinion- best bang for the money engine? cy-f270. complete engine at daves discount motors- 220 bucks- free shipping. -



Hey Thx Sunoco.
I totally agree and Im all for learning to make repairs myself and also finding out ways to Mcguyver some stuff if needed because theres no shops nearby or open where Im at especially on weekends when we do most of our running sessions. So we have to make do and rely on each other and whatever knowledge skills we may have collectively. I understand thats part of the hobby and Ive learned a lot.

What Im having trouble learning are these freekin carburators!!! They have been a pain the a$$ and have been the majority of issues Ive seen. What Im finding out is that theres not a lot of info on the subject and not a lot of people truly knowledgeable about them either. The majority of folks know the basic to richen\lean etc but as to the inner workings on what else could be causing issues i think they stop there. No offense to anyone, because i myself dnt know much about them. Its seems Walbro likes to keep that part secret on how to service their carbs or something. Ive researched the hell out of youtube on how to service and\or rebuild these walbro carbs (and found next to nothing). One site basically has you either sending them the carb to service or ordering some special tool (and i think u have to be a dealer to get the tool smh) and it doesn't tell you how to use the tool. To get any enjoyment out of this hobby ill definitely have to master that.

See next post above for latest update
 
Phill

Phill

Well-Known Member
Messages
1,996
Likes
62
Location
Yeppoon QLD Au
Hey Thx Sunoco.
I totally agree and Im all for learning to make repairs myself and also finding out ways to Mcguyver some stuff if needed because theres no shops nearby or open where Im at especially on weekends when we do most of our running sessions. So we have to make do and rely on each other and whatever knowledge skills we may have collectively. I understand thats part of the hobby and Ive learned a lot.

What Im having trouble learning are these freekin carburators!!! They have been a pain the a$$ and have been the majority of issues Ive seen. What Im finding out is that theres not a lot of info on the subject and not a lot of people truly knowledgeable about them either. The majority of folks know the basic to richen\lean etc but as to the inner workings on what else could be causing issues i think they stop there. No offense to anyone, because i myself dnt know much about them. Its seems Walbro likes to keep that part secret on how to service their carbs or something. Ive researched the hell out of youtube on how to service and\or rebuild these walbro carbs (and found next to nothing). One site basically has you either sending them the carb to service or ordering some special tool (and i think u have to be a dealer to get the tool smh) and it doesn't tell you how to use the tool. To get any enjoyment out of this hobby ill definitely have to master that.

See next post above for latest update
Could be an air leak at the manifold.
Did you install new gaskets or an aluminium manifold?
When it's idling spray WD40 around the inlet and see if the revs change.
 
P

pfrederi1

Well-Known Member
Messages
85
Likes
4
Thanks to all ur inputs. I havent been on here for a lil bit because I was so frustrated and pissed I needed a break. I finally just dove in and went for broke. I disassembled the carb completely. Sprayed it out with CRC Cleaner let it dry then used some compressed air and blew out every crevice. Reassembled. Still didnt start (frustration level increase).

Next moved on to the engine:
Broke down the engine and rebuilt the top end. Now someone may be able to lend some more insight on this but the piston looked like it was BBQd and I still had compression. Remember it started with the piston like this. I didnt notice any gouges or any ring wear against the lines. For the most part is was just the carbon build up. Anyone have any insight on what may have caused this issue?

Rebuilt the top end and reassembled loctite etc. Put the carb back on that i cleaned. Crossed my fingers and pulled 3 times and she responded. Oh sign of life. 4th pull and she came to life. I almost cried LOL!!!! Went thru a lil minnie break in process and she starts now on 2-3 pulls (crossing fingers).
 alt=  alt=
 
Impalassman

Impalassman

Well-Known Member
Messages
105
Likes
8
Congrats I too had issues and a new coil got me running. Hope she runs for you for a long while man ...sincerely Johnny
 

Members online

  • Ironman123

Latest posts

Top