Xt carb help

Med 382

New Member
Messages
1
I bought a used rampage xt. It will start 4th pull everytime. Idles and will run for a couple of min and dies from a lack of fuel. Plug is dry when I check it. I have reset the carb to factory settings and nothing seems to help. From what I have been reading the simplest thing to do is get a new carb. This is where my confusion comes in at, which carb do I get? The pull rope cover says it is a zenoah G270RC. I don't know what CC it is or what carb I should replace my old one with? Thanks for any help.
 

Phill

Well-Known Member
Messages
2,202
Location
Yeppoon QLD Au
Use a Walbro 668 but check that you don't have a tank venting issue first.
When it stops take the fuel cap off and listen for air rushing in.
 

Dobber72

Well-Known Member
Messages
78
Location
Booneville
I bought a used rampage xt. It will start 4th pull everytime. Idles and will run for a couple of min and dies from a lack of fuel. Plug is dry when I check it. I have reset the carb to factory settings and nothing seems to help. From what I have been reading the simplest thing to do is get a new carb. This is where my confusion comes in at, which carb do I get? The pull rope cover says it is a zenoah G270RC. I don't know what CC it is or what carb I should replace my old one with? Thanks for any help.
Vent your fuel cap lid sounds like. I would check that before I went to ordering new carbs that are a pain to ever get right.
I bought a used rampage xt. It will start 4th pull everytime. Idles and will run for a couple of min and dies from a lack of fuel. Plug is dry when I check it. I have reset the carb to factory settings and nothing seems to help. From what I have been reading the simplest thing to do is get a new carb. This is where my confusion comes in at, which carb do I get? The pull rope cover says it is a zenoah G270RC. I don't know what CC it is or what carb I should replace my old one with? Thanks for any help.
 

Phill

Well-Known Member
Messages
2,202
Location
Yeppoon QLD Au
I bought a used rampage xt. It will start 4th pull everytime. Idles and will run for a couple of min and dies from a lack of fuel. Plug is dry when I check it. I have reset the carb to factory settings and nothing seems to help. From what I have been reading the simplest thing to do is get a new carb. This is where my confusion comes in at, which carb do I get? The pull rope cover says it is a zenoah G270RC. I don't know what CC it is or what carb I should replace my old one with? Thanks for any help.
I saw the pic of the carb you posted on Large Scale.
It's a POS chinese clone.
Chuck it and get a genuine Walbro 668.
 

Members online

No members online now.

Latest posts

Top