Won’t idle

Redredcat0223

Member
Messages
8
Location
Glendale,Arizona
Not sure but I think it’s bad fuel,truck has always ran great but today I filled the tank with my fuel that I use but it stays stored in my house and is 5 months old ,I shook the can before filling,the truck started up fine ran fine fir about 1 min then just shut off and wouldn’t start back up unless I was full throttle on the remote and let it take off but after awhile it slowly started to bog down and have no power then just died,I reset the carb needles with it on a box and got it running but still had to give it throttle and it will not idle at all ,there are no leaks of any kind anywhere,could this be a bad fuel situation,any help I greatly appreciate
 

biggo

Well-Known Member
Messages
71
Location
USA, Baltimore, MD
Not sure but I think it’s bad fuel,truck has always ran great but today I filled the tank with my fuel that I use but it stays stored in my house and is 5 months old ,I shook the can before filling,the truck started up fine ran fine fir about 1 min then just shut off and wouldn’t start back up unless I was full throttle on the remote and let it take off but after awhile it slowly started to bog down and have no power then just died,I reset the carb needles with it on a box and got it running but still had to give it throttle and it will not idle at all ,there are no leaks of any kind anywhere,could this be a bad fuel situation,any help I greatly appreciate
I;m running fuel from last summer so no, highly doubt its a fuel issue. Have you checked the linkage or your transmitter settings? Have you tried adjusting the idle screw?
 

V8srfun

Active Member
Messages
29
I wonder if you got a piece of dirt or something in your carb. I would disassemble it and clean it.
 

biggo

Well-Known Member
Messages
71
Location
USA, Baltimore, MD
Have you tried adjusting the idle screw. Screw it in a little and give it a try. Recently did just that to my XT.
 

Members online

No members online now.

Latest posts

Top