Wheel nut very hot after run

sempaidavid4355

Junior Member
Messages
19
I was running my XT-E and after a few minutes a front wheel flew off. Never found the nut, but while I was checking it out I went to check the other nuts and the passenger side rear nut was so hot it burnt my hand on contact. The rear dog one was pretty hot too. I haven't torn into it yet, but my guess is that the bearing is fried. Thoughts?


Also, anyone know which size wheel nut I need. These aren't like the ones on my MT. They look like a standard nut with a nylon insert. Maybe I'll just hit Home Depot.


Sent from my iPhone using Tapatalk
 
Last edited by a moderator:

chapinb

Senior Member
Messages
141
Location
Albany
Sorry don't know size, but year check all the bearings. Check the bearing holders on the wheel side too, it could have melted the plastic.

Time to upgrade the bearings and/or holders.
 

sempaidavid4355

Junior Member
Messages
19
Well I just pulled the wheel and it isn't the bearings. The rim itself is stripped out. I guess pulling wheelies is too much for these rims, and I haven't even tried 8s yet.

Sent from my iPhone using Tapatalk
 

Ol' fart

Well-Known Member
Vendor
Messages
1,242
Location
Saratoga CA
Time for an upgrade

This is a common problem with Redcats. The bearings are just too small. My 7075rc bearing holders come with much larger bearings. You may also want to switch over to HPI wheel adapters too. Mine or Robs will work fine and you won't have your wheels falling off anymore.
 

Members online

No members online now.

Latest posts

Top