• Welcome to RedcatRampageForum! Are you a Redcat fan? If so you're in luck as you've have arrived to the biggest and best RedcatRampage RC community.

    Come join our community and ask your questions, show off your Recat RCs and share your experience!

The XT - XB - XB-E Improvement Thread

lumber38

Junior Member
Messages
24
I have not had any issues with the tires as of yet(on the fifth tank). I just been breaking bolts on the front end. The allen bolts that tie the a arm and hub together, so I replaced them with 10/32 socket heads with a 1 inch shank 10/32 x 2 bolt and nylon lock nut.
 

camo

Senior Member
Messages
194
Location
Houston, TX
@ Darin. The axles are the first thing you have to address on future revisions, beefing them up will help but some work will also be needed at the hubs. bigger bearings may be? any way here is a pic.
 
Last edited by a moderator:

TheNewbe

Contributor
Messages
283
Location
Waco, Tx
Like to have the xt be able to sit a little higher since it is a monster truck but still no major breakage, just lost a steering assembly screw.
 

bbuzzard

Contributor
Messages
447
Location
Broadlands, VA
Just lost the grub screw on the center diff rear hub...no big deal since I didn't loctite it but I did notice that the manual is screwed up regarding the part numbers. I found that the part number for the grub screw doesn't match the schematics vs. the parts list. There are numerous discrepancies that need to be addressed.
 

camo

Senior Member
Messages
194
Location
Houston, TX
If you trust these manuals you'll find yourself in a world to hurt. cen FS himoto redcat..... all them have the same crappy manuals. They are good for reference but that is about it, eg: find the stock rear hubs..... you won't even find them LOL, but I guess that makes the hobby a bit more interesting at times :D
 

bbuzzard

Contributor
Messages
447
Location
Broadlands, VA
camo said:
If you trust these manuals you'll find yourself in a world to hurt. cen FS himoto redcat..... all them have the same crappy manuals. They are good for reference but that is about it, eg: find the stock rear hubs..... you won't even find them LOL, but I guess that makes the hobby a bit more interesting at times :D
IMO, that is something that should be rectified. It is a trust issue if you think about it, though(the HPI manuals, for example). To ensure that the manual is correct, at least with the part numbers, is critical. This is the improvement thread and I'm not assuming everyone here is a seasoned Redcat vet.
 

rob64n

Contributor
Messages
1,029
Location
Franklin,Indiana
with a new body coming in and all, will we be able to get the yellow wheels and wings, i know i already have 1 of each but would like spares, to keep my color scheme.
 

TheNewbe

Contributor
Messages
283
Location
Waco, Tx
I guess this would count as a manual hiccup. Ordered a replacement part and it didn't come with all the parts that were pictured:(
 

bbuzzard

Contributor
Messages
447
Location
Broadlands, VA
I want to thank Darin for standing behind his product and rectifying some of the shortcomings of the stock setup of the XB for me. IMO, the V2 of these x-series buggies is gonna be great, if the bearings, tire/wheelset, tank size and steering linkage design are revised.


Thanks, my man!
 

powerslave69

Senior Member
Messages
277
Location
Alaska
servos bad

RedcatRacing said:
I would greatly appreciate those that currently own XT's, XB's or XB-E's to discuss issues they find in this thread.
It will help us with resolutions to problems along with be able to work closer with the factory to get them worked out.


If you currently don't own one of these vehicles, please try not comment unless you have first hand knowledge of these issues as keeping this particular thread as straight to the point as possible would be best.


Thanks to everyone!


Darin
I received my XT and right out of the box I turned on the Radio and receiver and I noticed my servos were twitching very bad and making a lot of noise. I've read the same problem from other owners in this forum before I got mine and sure enough I got it too. Decided to wait for my order of Hitec 5755 to come in before I drive this truck. Failsafe doesn't work either. It goes on 'full throttle" mode when I swtich off my Radio. :(
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Members online

No members online now.
Top