• Welcome to RedcatRampageForum! Are you a Redcat fan? If so you're in luck as you've have arrived to the biggest and best RedcatRampage RC community.

    Come join our community and ask your questions, show off your Recat RCs and share your experience!

Rampage XT wont run correctly

tayloroffroad

New Member
Messages
3
the truck was ran a bit hard during the break in and blow a hole in the rubber tube from the back of the engin to the exhaust, repalaced that and now it wont run properly. cleaned cab, have hi and low set to factory. starts up but has no power inless you turn the high and low out then it will move on its own power but will stall out when aplying brakes. not sure what eles to check. thanks
 

tayloroffroad

New Member
Messages
3
yes. not i a customer A friend of mine... it wasent broke in before it was opened up.
now it will start but when you think its running good while on the stand. put it on the ground and it will bog out then seem like its gonna go then bog out and then stall. then when you restart it its ideling really high.
adjust the high and low a tinny bit and seems to have effect. i have pulled the carb off and cleaned it checked gaskets on the back side of carb all good there. im wondering if its the motor.
 

realtee30

Well-Known Member
Messages
149
Did you check to make sure the ignition coil is sending a spark to the spark plug?
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Members online

No members online now.

Latest posts

Top