• Welcome to RedcatRampageForum! Are you a Redcat fan? If so you're in luck as you've have arrived to the biggest and best RedcatRampage RC community.

    Come join our community and ask your questions, show off your Recat RCs and share your experience!

My RedCat XB is a piece of junk.

Robxb

New Member
Messages
1
Just got my XB. Have not even been able to run it. Took out of box and tried to move it back and forth. Wheels are completely locked up. Called RedCat customer no service. They will not help me and told me I could not return it. I nownow have $650 paper weight. Would not recommend this product to anyone.
 

gdl357

Active Member
Messages
29
Location
Montreal, Quebec Canada
Well all I have to say is... If you bought a 1/5 I hope you have RC experience. You don't just go out and buy a 1/5 gasser as a first truck.

Second... what's so hard about taking it apart until you find the defective or binding part. A couple of gears and some shafts...nothing a 10 yo couldn't fix.
Not trying to diss you but China builds those trucks, not Redcat USA. Not recommending a product because of a minor 1 odd case is not the way to do it in a forum.
 

Tvbest

Member
Messages
22
Just got my XB. Have not even been able to run it. Took out of box and tried to move it back and forth. Wheels are completely locked up. Called RedCat customer no service. They will not help me and told me I could not return it. I nownow have $650 paper weight. Would not recommend this product to anyone.
Well if you feel it is junk I will buy it from you for 300.
 

Haroldbee

Well-Known Member
Messages
57
Just got my XB. Have not even been able to run it. Took out of box and tried to move it back and forth. Wheels are completely locked up. Called RedCat customer no service. They will not help me and told me I could not return it. I nownow have $650 paper weight. Would not recommend this product to anyone.
DON'T JUNK IT YET, MY BROTHER. The problem is quite fixable. You'll have to now learn to take your vehicle apart, eventually. So why not start now. Before I continue, you need to be aware that part of the 5th scale rc fun is becoming your own mechanic through troubleshooting. So, let's get down to solving your problem:

Step #1: Photograph the details of the throttle linkage from its servo and then detach it.
#2: Take the exhaust off, and then unbolt the engine from the chassis.
#3: Carefully take it out of the vehicle. Having done that, see if you can move the vehicle back and forth. If it moves, the problem is linkage-related. If it still doesn't move, go to the next step:
#4: Take off the radio tray, to expose the brakes system with its brake pads. (Again, photograph things as you progress.)
#5: Examine everything to see if there is binding the brakes. If nothing can be seen...
#6: Look at the side of the little unit with the pinion. There are 2 holes with long set screws in them. Insert a hex screw into the upper hole and back the set screw out. Maybe it's too tight against the brake pad. Do the same with the lower screw. That MAY be why the vehicle wasn't moving.

BEST OF LUCK!



Just got my XB. Have not even been able to run it. Took out of box and tried to move it back and forth. Wheels are completely locked up. Called RedCat customer no service. They will not help me and told me I could not return it. I nownow have $650 paper weight. Would not recommend this product to anyone.
 

biggo

Well-Known Member
Messages
84
Location
USA, Baltimore, MD
Just got my XB. Have not even been able to run it. Took out of box and tried to move it back and forth. Wheels are completely locked up. Called RedCat customer no service. They will not help me and told me I could not return it. I nownow have $650 paper weight. Would not recommend this product to anyone.
I wouldn't remove the motor because you can remove the gearing to disengage the motor, so no need to remove it.
Check the brakes like Haroldbee said.
Also check the trans nuts holding your gears making sure they aren't over tightened.
Although possible, I doubt its the clutch on a new rig.

Hope this helps. Either way you'll get some great help here.
 

Tvbest

Member
Messages
22
In my experience if you tighten the bolts that come out from the clutch holding the gear plate on too much or uneven it will bind up the clutch Bell causing your car not to move try loosening the bolts a little bit and see if the car moves freely.
 

denniswoo

New Member
Messages
3
I would start with the simple first, make sure the brake section of the throttle servo is not set on, you can remove the side gear cover then remove the gear off of the clutch drive see if it rolls, just keep doing things step by step until you find the trouble. It probably is something very simple, these things from the factory use crappy parts, it will take about 400 more to get this buggy to hold up to the abuse we give them. I have an older xb v1 and it has held up to most of my abuse. The plastic parts for the gear side cover flex and will strip your gears. Will need metal steering parts, be careful torquing screws down. People use lock-tight on them i wouldn't advise it myself have had too many screw heads strip out.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Members online

No members online now.

Latest posts

Top