• Welcome to RedcatRampageForum! Are you a Redcat fan? If so you're in luck as you've have arrived to the biggest and best RedcatRampage RC community.

    Come join our community and ask your questions, show off your Recat RCs and share your experience!

MT won’t start

1977dam

New Member
Messages
4
New to the MT had some issues during break in I would go and slow down to make a turn and she would die so I would restart it now breaking is done and she will not start I have change the plug I have checked for fire check for compression make sure she was getting fuel it don’t even act like it wants to start I have put the high and low back on factory settings I have tried to adjust low end to see if I can get it to start
 

realtee30

Well-Known Member
Messages
112
Sorry your having those issues. Are you running a stock motor? When I brought my MT new, I didn't even start the factory motor. Took it off and sold right out the box. Replaced it with an OBR 30.5 full mod. Never had a starting issue with it thus far....
 

realtee30

Well-Known Member
Messages
112
I don't know much about those stock motors. It seems you've checked all the main run points. It could be something inside the carburetor. DDM have rebuild carb kits for a few bucks. Worth a try....
 

1977dam

New Member
Messages
4
I don't know much about those stock motors. It seems you've checked all the main run points. It could be something inside the carburetor. DDM have rebuild carb kits for a few bucks. Worth a try....
I have put a new carburetor on it
 

Phill

Well-Known Member
Messages
2,403
Location
Yeppoon QLD Au
I found the best cure for a stock motor is to replace it with a Zenoah.
You'll need to use your stock front cover to mount it.
 

Easymoneykd

Member
Messages
9
I was having a lot of these when I first got my truck aswell. First things first, you'll definitely want a spark plug asap. you may or may not need it rn but eventually you will because for some reason that first couple of tanks you run to break in get dirty real quick. Second you may want to check your running the right fuel mix, third youll want to buy yourself a new controller. The stock controller mine came with was fine for a bit but then it stated to cut power mid drive?‍♂️ ive found out that getting a controller with a screen that shows you all your mixes and things of that sort really really helps. I had problems for the longest time and soon as got this ive never had a problem again. Radiolink link controller is what I use, a little pricey but definitely worth it
 

Timreefer

Member
Messages
11
Location
Dighton ma
Mine would not start after running. No spark. Looked at everything twice. Come to find out the 2 screws on top of the motor were to tight and not allowing the killswitch button to release. Loosened both phillip screws alittle never had an issue again with starting.
 

cfrank

New Member
Messages
2
New to the MT had some issues during break in I would go and slow down to make a turn and she would die so I would restart it now breaking is done and she will not start I have change the plug I have checked for fire check for compression make sure she was getting fuel it don’t even act like it wants to start I have put the high and low back on factory settings I have tried to adjust low end to see if I can get it to start
i had the same issue i finally checked the gap on plug and it was off fix the gap now runs great and starts right up
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Members online

No members online now.

Latest posts

Top