• Welcome to RedcatRampageForum! Are you a Redcat fan? If so you're in luck as you've have arrived to the biggest and best RedcatRampage RC community.

    Come join our community and ask your questions, show off your Recat RCs and share your experience!

Killer bee kill switch , installed on rampage mt the remote works killin the engine but the red button on motor does not kill motor now?

Brotherskrill73

New Member
Messages
3
Location
Santee,ca
Hello , installed new killerbee kill switch in rampage mt ,the remote kill works fine with remote tx, but kill switch on motor dosent kill the motor have to push button on remote to kill it ,is that normal? Thanks
 

Brotherskrill73

New Member
Messages
3
Location
Santee,ca
Anyone have this issue of killer bee kill switch work from remote but engine kill switch not cut motor off? It is a new G320RC motor with aftermarket pipe and finally have it starting fairly quick 2 or 3 pulls and have not wide opened throttle it yet been breaking in for short times heat cycles
 

Attachments

  • 16201794143064131025588978302292.jpg
    16201794143064131025588978302292.jpg
    365.1 KB · Views: 6
  • 16201794427446767731927301476102.jpg
    16201794427446767731927301476102.jpg
    358.1 KB · Views: 6
  • 16201794627557698455240354982814.jpg
    16201794627557698455240354982814.jpg
    292.6 KB · Views: 6

realtee30

Well-Known Member
Messages
102
Check your connections between the kill switch wiring to the push button kill switch. You may have a loose or un-done connections. I use the Dynamite Kill Switch on my MT. No issues thus far.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Members online

No members online now.

Latest posts

Top