CVA Drive pins Keep Falling Out (looking for Fix)

P

pfrederi1

Well-Known Member
Messages
85
Likes
4
I know this has been posted in some form or fashion before but i couldnt find the fix that I need.


Someone suggested switching to dogbones and drive cups but i dnt believe redcat carries those parts anymore. And i read there are issues with that setup as well as far as not turning.

I also tried putting the rubber o rings over the pins as an added safety but the orings dnt last. The grub screw is also tightened and loctite and they still manage to fallout.

I believe i read from someone somehwere that they installed a metal ring over the axle. Cant seem to find that thread anymore. Does anyone know where I can find something like that to fit the CVA on the MT??

Thx
 
Impalassman

Impalassman

Well-Known Member
Messages
106
Likes
9
I actually put a carbon fiber 20mm ring over mine and secured them with body panel adhesive. Got the carbon fiber toobe off ebay and trim to lengths I needed .cut easily with my dremel and a cut off wheel. Did this to my drive cups also. Had to sand the dog bone pins some to give good clearance of the carbon fiber sleeves. Got this idea from looking at the dark soul drive cup toobz for baja.
 
P

pfrederi1

Well-Known Member
Messages
85
Likes
4
I actually put a carbon fiber 20mm ring over mine and secured them with body panel adhesive. Got the carbon fiber toobe off ebay and trim to lengths I needed .cut easily with my dremel and a cut off wheel. Did this to my drive cups also. Had to sand the dog bone pins some to give good clearance of the carbon fiber sleeves. Got this idea from looking at the dark soul drive cup toobz for baja.

Hey Thx Impalassman
Was the 20mm a tight fit? Was it hard to get on the axle? How did you get it on? Im asking because if its loose to get on Im wondering how it will stay on once driving. Dnt know if the body panel adhesive is strong enough for you.

Im looking on ebay was this the size you got?? 20x18x500mm?

Thanks for your input man. Im getting other great advice from other members appreciate them all. Just want the best that works so I dnt have to muck aroiund with this thing all the time.
 
Impalassman

Impalassman

Well-Known Member
Messages
106
Likes
9
Hey Thx Impalassman
Was the 20mm a tight fit? Was it hard to get on the axle? How did you get it on? Im asking because if its loose to get on Im wondering how it will stay on once driving. Dnt know if the body panel adhesive is strong enough for you.

Im looking on ebay was this the size you got?? 20x18x500mm?

Thanks for your input man. Im getting other great advice from other members appreciate them all. Just want the best that works so I dnt have to muck aroiund with this thing all the time.
I have yet to test the body panel adhesive but it holds metal body panels on. And I believe that was the size. It pretty easily slid on. But is snug.
 
Phill

Phill

Well-Known Member
Messages
2,007
Likes
65
Location
Yeppoon QLD Au
I know this has been posted in some form or fashion before but i couldnt find the fix that I need.


Someone suggested switching to dogbones and drive cups but i dnt believe redcat carries those parts anymore. And i read there are issues with that setup as well as far as not turning.

I also tried putting the rubber o rings over the pins as an added safety but the orings dnt last. The grub screw is also tightened and loctite and they still manage to fallout.

I believe i read from someone somehwere that they installed a metal ring over the axle. Cant seem to find that thread anymore. Does anyone know where I can find something like that to fit the CVA on the MT??

Thx
Part number is 050032 for the axles to use dogbones.
They're all over the web.
I have them on all corners.
No problems turning in the last 4 yrs.
 

Members online

No members online now.

Latest posts

Top