Clutch problem

jeepzj

Member
Messages
6
Location
Nj
Brand new Rampage Mt V3 right out of the box trying to break the motor in can't even get it to engage unless it's almost full throttle I have just adjust the throttle linkage and make sure everything on the servers were good but when it does engage truck will shake any help would be appreciated
 

Ice_2k

Senior Member
Messages
1,391
Is the engine revving normally and the clutch is not engaging or does the engine have problema revving? Did you check that the throttle servo is pulling the carb butterfly all the way? Can you post a video of the issue?
 

jeepzj

Member
Messages
6
Location
Nj
Is the engine revving normally and the clutch is not engaging or does the engine have problema revving? Did you check that the throttle servo is pulling the carb butterfly all the way? Can you post a video of the issue?

Is the engine revving normally and the clutch is not engaging or does the engine have problema revving? Did you check that the throttle servo is pulling the carb butterfly all the way? Can you post a video of the issue?
I figured it out thank you for the info the engine was revving perfectly throttle everything was adjusted perfectly but it wouldn't not go unless for throttle so I took the clutch out in the spring was broken in the clutch and the Rampage was brand new right out of the box
 

Ice_2k

Senior Member
Messages
1,391
Glad you got it sorted out. Did you reach out to Redcat to get it replaced under warranty? Although, while you have the clutch disassembled you might as well just go ahead and install an 8k clutch, it makes a ton of difference.
 

Members online

Latest posts

Top