• Welcome to RedcatRampageForum! Are you a Redcat fan? If so you're in luck as you've have arrived to the biggest and best RedcatRampage RC community.

    Come join our community and ask your questions, show off your Recat RCs and share your experience!

chimera no spark need ideas on what it could be.. new plug new coil from another unit that works..

pro87stang

Member
Messages
17
No spark.. just picked up a Chimera and I am not able to get any spark... I replace spark plug with a new one... still no spark.. replace coil from one of my other 1/5 scales and still no spark. this unit does not have a kill switch. I did notice some scratches on the flywheel magnetic (some what deep) could that be it?
 

realtee30

Well-Known Member
Messages
231
You can try lightly sanding the flywheel magnet but you may have to replace that flywheel.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Members online

No members online now.

Latest posts

Top